User Tag List

Results 1 to 8 of 8

Thread: 2001 Jeep TJ multifunction switch issue...

  1. #1
    PondSkum's Avatar
    Join Date
    Jan 2012
    Location
    Deer Park, TX
    Posts
    1,505
    Post Thanks / Like
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    10

    2001 Jeep TJ multifunction switch issue...

    I changed my multifunction switch because my fog lights would stay on. After installing new switch, turn signals, hazards and brake lights do not work. Middle (3rd) brake light works, but left and right do not. Tail lights and headlights/fogs work fine now. I took new switch back off and put old one back on and still doesn't work. Fuses are good and relays seem good, even switched a few out to see if it would work, still nothing. Ready to pull my hair out, any ideas? 2001 TJ
    2001 TJ - PondSkum
    Build in progress....

    "The wisest mind has something yet to learn." ~ George Santayana

  2. #2
    ExpoLj's Avatar
    Join Date
    Apr 2013
    Location
    Bryan
    Posts
    94
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    5

    2001 Jeep TJ multifunction switch issue...

    Last time we had an issue with a mutil function switch it wasn't actually in the switch but in the vehicle side of the wiring harness of the switch. The pins get corroded and it broken. More than likely taking it apart to install the new switch loosened the pins causing your new issues. Check it out

  3. #3
    PondSkum's Avatar
    Join Date
    Jan 2012
    Location
    Deer Park, TX
    Posts
    1,505
    Post Thanks / Like
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    10
    After messing with it some more, I noticed the connector on the harness was cracked. and was very brittle. So I thought the same thing that you mentioned that maybe it wasn't making good connection now. So I ordered a new connector and installed it. Still didn't work. So after searching the fuse box again for at least the 20th time, I found a fuse in the PDC under the hood for MF Switch. it was blown. Switched it out with another one, and the turn signals started working, but hazard would blow the fuse again. Put the old MF switch back on, and everything working fine. There has to be an issue inside my NEW MF switch. So now I get to try to see if they will exchange it or give me a refund.
    2001 TJ - PondSkum
    Build in progress....

    "The wisest mind has something yet to learn." ~ George Santayana

  4. #4
    TXRED is offline Chapter President Bryan/College Station Chapter
    TXRED's Avatar
    Join Date
    Feb 2012
    Posts
    206
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    7
    Ohm out the switch and check for continuity.

  5. #5
    PondSkum's Avatar
    Join Date
    Jan 2012
    Location
    Deer Park, TX
    Posts
    1,505
    Post Thanks / Like
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    10
    I checked continuity per the service manual. This is where the flasher relay plugs in. On old switch, there is no continuity between 1 and 5, on new switch there is continuity there. So it has to have a short inside somewhere. According to manual, when flasher switch is on, there should be continuity between 3 & 5. But it has continuity between 3, 5, & 1, which should not happen.

    I contacted quadratec today, and they are going to exchange it for me. sending me a shipping label to send this one back. But the new one is backordered 1-2 weeks now. But I will just put my old switch back in for now and unplug my fog light fuse like I had before.

    flasher relay.jpg
    2001 TJ - PondSkum
    Build in progress....

    "The wisest mind has something yet to learn." ~ George Santayana

  6. #6
    TXRED is offline Chapter President Bryan/College Station Chapter
    TXRED's Avatar
    Join Date
    Feb 2012
    Posts
    206
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    7
    Electronic parts keep getting more and more sketchy. I have run into similar problems while working on other vehicles. New out of the box but no good.

  7. #7
    EastTxRedneck's Avatar
    Join Date
    Mar 2012
    Location
    Burleson County
    Posts
    304
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    6
    another real common issue on tj light issues is with wiring for a trailer plug, cant tell you how many times ive had to remove or repair it

  8. #8
    PondSkum's Avatar
    Join Date
    Jan 2012
    Location
    Deer Park, TX
    Posts
    1,505
    Post Thanks / Like
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    Rep Power
    10
    Quote Originally Posted by EastTxRedneck View Post
    another real common issue on tj light issues is with wiring for a trailer plug, cant tell you how many times ive had to remove or repair it
    Haven't had any issues with my trailer wiring. I just re-wired it 2 years ago to be able to pull my pop-up. It has a 7-pin plug, and I only had a 4 pin before. I even wired up the 12V hot wire to help charge the battery on the camper via the charging system on the Jeep.
    2001 TJ - PondSkum
    Build in progress....

    "The wisest mind has something yet to learn." ~ George Santayana

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •